Выполнение произвольных команд в Snoopy

Дата публикации:
27.10.2008
Дата изменения:
05.11.2008
Всего просмотров:
22836
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Snoopy 1.x
Уязвимые версии: Snoopy 1.2.3, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю скомпрометировать целевую систему.

Уязвимость существует из-за недостаточной обработки данных в функции "_httpsrequest()" перед вызовом "exec()". Удаленный пользователь может передать специально сформированный URL сценарию, вызывающему функции "fetch()" или "submit()", и выполнить произвольные команды на системе с привилегиями Web сервера.

URL производителя: snoopy.sourceforge.net

Решение: Установите последнюю версию 1.2.4 с сайта производителя.

Ссылки: http://sourceforge.net/project/shownotes.php?release_id=635111

или введите имя

CAPTCHA