Межсайтовый скриптинг в cpCommerce

Дата публикации:
21.10.2008
Всего просмотров:
1381
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2008-4121
CVE-2008-4637
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
cpCommerce 1.x
Уязвимые версии: cpCommerce версии до 1.2.4

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "search" в сценарии search.php и в параметре "name" в сценарии sendtofriend.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: cpcommerce.cpradio.org

Решение: Установите последнюю версию 1.2.4 с сайта производителя.

Ссылки: http://www.datensalat.eu/~fabian/cve/CVE-2008-4121-cpcommerce.html

или введите имя

CAPTCHA