Несколько уязвимостей в PhpWebGallery

Дата публикации:
17.10.2008
Всего просмотров:
1298
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
PhpWebGallery 1.x
Уязвимые версии: PhpWebGallery 1.7.2, возможно более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю выполнить произвольные SQL команды в базе данных приложения и скомпрометировать целевую систему.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "sort_by" в сценарии comments.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "sort" в сценарии plugins/event_tracer/event_list.php перед вызовом функции "create_function()". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP код на целевой системе с привилегиями Web сервера.

URL производителя: www.phpwebgallery.net

Решение: Установите последнюю версию 1.7.3 с сайта производителя.

Ссылки: PhpWebGallery <= 1.7.2 Session Hijacking / Code Execution Exploit

или введите имя

CAPTCHA