Переполнение буфера в Sun Solaris

Дата публикации:
15.10.2008
Дата изменения:
17.11.2008
Всего просмотров:
1344
Опасность:
Средняя
Наличие исправления:
Частично
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Локальная сеть
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Sun Solaris 8
Sun Solaris 9
Уязвимые версии: Sun Solaris 8, 9

Описание:
Уязвимость позволяет удаленному пользователю скомпрометировать целевую систему.

Уязвимость существует из-за ошибки проверки границ данных в функции "adm_build_path()" в системном демоне Solstice AdminSuite ("sadmind"). Удаленный пользователь может с помощью специально сформированного RPC запроса вызвать переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: www.sun.com

Решение: Способов устранения уязвимости не существует в настоящее время.

Журнал изменений:

21.10.2008
Добавлен PoC код.
17.11.2008
Добавлена ссылка на уведомление от производителя.

Ссылки: Solaris 9 [UltraSPARC] sadmind Remote Root Exploit
A Buffer Overflow Security Vulnerability in the Solaris sadmind(1M) Daemon May Lead to Execution of Arbitrary Code
http://risesecurity.org/advisories/RISE-2008001.txt

или введите имя

CAPTCHA