Переполнение буфера в RaidenFTPD

Дата публикации:
14.10.2008
Всего просмотров:
937
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
RaidenFTPD 2.x
Уязвимые версии: RaidenFTPD 2.4.3615, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании и скомпрометировать целевую систему.

Уязвимость существует из-за ошибки проверки границ данных при обработке слишком длинных имен директории в запросах. Удаленный авторизованный пользователь может с помощью специально сформированной комбинации "CWD" и "MLST" команд вызвать переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: www.raidenftpd.com/en/

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: RaidenFTPD 2.4 build 3620 Remote Denial of Service Exploit

или введите имя

CAPTCHA