PHP-инклюдинг в DFF PHP Framework API

Дата публикации:
14.10.2008
Всего просмотров:
2328
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
DFF PHP Framework API
Уязвимые версии: DFF PHP Framework API

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "DFF_config[dir_include]" в сценариях include/DFF_affiliate_client_API.php, include/DFF_featured_prdt.func.php, include/DFF_mer.func.php, include/DFF_mer_prdt.func.php, include/DFF_paging.func.php, include/DFF_rss.func.php и include/DFF_sku.func.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/include/DFF_affiliate_client_API.php?DFF_config[dir_include]=[file]

URL производителя: opensource.datafeedfile.com//wikka.php?wakka=HomePage

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA