Межсайтовый скриптинг и раскрытие данных в XAMPP

Дата публикации:
17.06.2005
Дата изменения:
03.10.2008
Всего просмотров:
752
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Раскрытие важных данных
Раскрытие системных данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
XAMPP 1.x
Уязвимые версии: XAMPP 1.4.13, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение и получить доступ к важным данным.

Уязвимость существует из-за недостаточной обработки входных данных в URL в сценарии lang.php, перед сохранением данных в файл "lang.tmp". Удаленный пользователь может выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта при просмотре специально сформированных данных. Дальнейшая эксплуатация уязвимости может позволить злоумышленнику просмотреть содержимое произвольных файлов на системе с помощью символов обхода каталога в функции "include()".

URL производителя: www.apachefriends.org/en/xampp.html

Решение: Установите последнюю версию 1.4.14 с сайта производителя.

или введите имя

CAPTCHA