Межсайтовый скриптинг в WikyBlog

Дата публикации:
02.10.2008
Дата изменения:
05.03.2009
Всего просмотров:
1916
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
WikyBlog 1.x
Уязвимые версии: WikyBlog 1.7.1 RC2, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "key" в сценарии index.php/Special/Main/keywordSearch, в параметре "revNum" в сценарии index.php/Edit/Main/Home, в параметре "to" в сценарии index.php/Special/Main/WhatLinksHere, в параметре "user" в сценарии index.php/Special/Main/UserEdits и в URL, следующим за "index.php/". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: www.wikyblog.com

Решение: Установите последнюю версию 1.7.1 с сайта производителя.

Журнал изменений:

05.03.2009
Изменена секция «Решение».

Ссылки: http://www.digitrustgroup.com/advisories/web-application-security-wikyblog.html

или введите имя

CAPTCHA