Несколько уязвимостей в The Gemini Portal

Дата публикации:
30.09.2008
Дата изменения:
01.10.2008
Всего просмотров:
1454
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Раскрытие важных данных
Раскрытие системных данных
Обход ограничений безопасности
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
The Gemini Portal 4.x
Уязвимые версии: The Gemini Portal 4.7, возможно более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю обойти некоторые ограничения безопасности, получить доступ к важным данным и скомпрометировать целевую систему.

1. Уязвимость существует из-за некорректного ограничения доступа к сценарию admin.php. Удаленный пользователь может установить параметр файла куки "user" в имя администратора и параметр "name" в значение "users" и получить административный доступ к приложению.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "lang" в сценарии page/forums/bottom.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP.

URL производителя: www.arzdev.com/downloads/details/31/The+Gemini+Portal

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA