Переполнение буфера в CCProxy

Дата публикации:
30.09.2008
Всего просмотров:
2088
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
CCProxy 6.x
Уязвимые версии: CCProxy 6.61, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании и скомпрометировать целевую систему.

Уязвимость существует из-за ошибки проверки границ данных при обработке "CONNECT" запросов, отправленных HTTP прокси (по умолчанию, слушает на порту 808/TCP). Удаленный пользователь может с помощью специально сформированного "CONNECT" запроса, содержащего слишком длинное имя хоста, вызвать переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: www.youngzsoft.net/ccproxy/

Решение: Установите последнюю версию 6.62 с сайта производителя.

Ссылки: http://jbrownsec.blogspot.com/2008/09/ccproxy-near-stealth-patching.html

или введите имя

CAPTCHA