Межсайтовый скриптинг в phpMyAdmin

Дата публикации:
30.09.2008
Всего просмотров:
2066
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
phpMyAdmin 2.x
Уязвимые версии: phpMyAdmin версии до 2.11.9.2

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в функции "PMA_escapeJsString()" в сценарии libraries/js_escape.lib.php. Удаленный пользователь может с помощью специально сформированного запроса обойти некоторые фильтры и выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: www.phpmyadmin.net

Решение: Установите последнюю версию 2.11.9.2 с сайта производителя.

Ссылки: http://www.phpmyadmin.net/home_page/security.php?issue=PMASA-2008-8
http://jvn.jp/en/jp/JVN54824688/index.html

или введите имя

CAPTCHA