PHP-инклюдинг в x10 Automatic MP3 Script

Дата публикации:
29.09.2008
Всего просмотров:
1838
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
x10 Automatic MP3 Script 1.x
Уязвимые версии: x10 Automatic MP3 Script 1.5.5, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "web_root" в сценариях includes/function_core.php и templates/layout_lyrics.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/includes/function_core.php?web_root=[file]

URL производителя: www.x10media.com/mp3-script.php

Решение: Установите исправление с сайта производителя.

или введите имя

CAPTCHA