Выполнение произвольного PHP кода в Advanced Electron Forum

Дата публикации:
29.09.2008
Всего просмотров:
3010
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Advanced Electron Forum (AEF) 1.x
Уязвимые версии: Advanced Electron Forum 1.0.6, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю скомпрометировать целевую систему.

Уязвимость существует из-за небезопасного вызова функции "preg_replace()" с параметром "e". Удаленный пользователь может с помощью специально сформированного тега выполнить произвольный PHP код на целевой системе с привилегиям Web сервера. Пример:

[email]{${phpinfo()}}[/email]

URL производителя: www.anelectron.com

Решение: Установите последнюю версию 1.0.7 с сайта производителя.

Ссылки: http://www.anelectron.com/board/index.php?tid=3282
http://www.gulftech.org/?node=research&article_id=00131-09202008

или введите имя

CAPTCHA