Множественные уязвимости в Fedora

Дата публикации:
11.09.2008
Дата изменения:
11.09.2008
Всего просмотров:
2098
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2008-2928
CVE-2008-2929
CVE-2008-2932
Вектор эксплуатации:
Локальная сеть
Воздействие:
Межсайтовый скриптинг
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Fedora 8
Fedora 9
Уязвимые версии: Fedora 8, 9

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение, вызвать отказ в обслуживании и скомпрометировать целевую систему.

1. Уязвимость существует из-за ошибки проверки границ данных в различных Red Hat Directory Server CGI приложениях при обработке HTTP заголовка "Accept-Language". Удаленный пользователь может с помощью специально сформированного HTTP запроса вызвать переполнение буфера и выполнить произвольный код на целевой системе с привилегиями учетной записи root.

2. Уязвимость существует из-за недостаточной обработки данных, содержащих символ "%" в Directory Server Administration Express и Directory Server Gateway (DSGW). Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

3. Уязвимость существует из-за недостаточной обработки входных кодированных данных, содержащих символ "%". Удаленный пользователь может с помощью специально сформированного запроса к определенным CGI приложениям вызвать переполнение динамической памяти и выполнить произвольный код на целевой системе.

URL производителя: fedoraproject.org

Решение: Установите исправление с сайта производителя.

Ссылки: Fedora 8 Update: adminutil-1.1.7-1.fc8
Fedora 9 Update: adminutil-1.1.7-1.fc9

или введите имя

CAPTCHA