SQL-инъекция в Zen Cart

Дата публикации:
08.09.2008
Всего просмотров:
2970
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Zen Cart 1.x
Уязвимые версии: Zen Cart версии 1.2.0d по 1.3.8a

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю выполнить произвольные SQL команды в базе данных приложения.

1. Уязвимость существует из-за недостаточной обработки входных данных при добавлении или изменении товаров в карте покупателя. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

2. Уязвимость существует из-за недостаточной обработки входных данных в ключе массива "products_id". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

URL производителя: www.zen-cart.com

Решение: Установите исправление с сайта производителя.
www.zen-cart.com/forum/showthread.php?p=604473

Ссылки: http://www.zen-cart.com/forum/showthread.php?p=604473
http://www.gulftech.org/?node=research&article_id=00129-09042008

или введите имя

CAPTCHA