Несколько уязвимостей в phpAdultSite CMS

Дата публикации:
08.09.2008
Всего просмотров:
953
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
phpAdultSite CMS 2.x
Уязвимые версии: phpAdultSite CMS 2.3.2, возможно более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение и выполнить произвольные SQL команды в базе данных приложения.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "results_per_page" в сценарии as_archives.php при возвращении сообщения об SQL ошибке. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "results_per_page" в сценарии as_archives.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

URL производителя: www.phpadultsite.com

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: http://www.davidsopas.com/2008/09/phpadult-cms-exploit/

или введите имя

CAPTCHA