Множественные уязвимости в ZoneMinder

Дата публикации:
02.09.2008
Дата изменения:
29.03.2009
Всего просмотров:
2501
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2008-3880
CVE-2008-3881
CVE-2008-3882
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Неавторизованное изменение данных
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
ZoneMinder 1.x
Уязвимые версии: ZoneMinder 1.23.3, возможно более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение, выполнить произвольные SQL команды и скомпрометировать целевую систему.

1. Уязвимость существует из-за недостаточной обработки входных данных. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "filter" в сценарии zm_html_view_event.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

3. Уязвимость существует из-за недостаточной обработки входных данных в параметре "run_state" в сценарии zm_html_view_state.php и в некоторых параметрах в сценарии zm_html_view_events.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные команды на системе с привилегиями Web сервера.

URL производителя: www.zoneminder.com

Решение: Установите последнюю версию с сайта производителя.

Журнал изменений:
29.03.2009
Изменена секция "Решение"

или введите имя

CAPTCHA