Небезопасная обработка временных файлов в GpsDrive

Дата публикации:
31.08.2008
Дата изменения:
26.02.2009
Всего просмотров:
1748
Опасность:
Низкая
Наличие исправления:
Инстуркции по устранению
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2008-4959
CVE-2008-5380
CVE-2008-5703
Вектор эксплуатации:
Локальная
Воздействие:
Повышение привилегий
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
GpsDrive 2.x
Уязвимые версии: GpsDrive 2.x

Описание:
Обнаруженные уязвимости позволяют локальному пользователю повысить свои привилегии на системе.

1. Уязвимость существует из-за того, что сценарий "geo-code" небезопасным образом обрабатывает временные файлы. Локальный пользователь может с помощью специально сформированной символической ссылки повысить свои привилегии на системе.

2. Уязвимость существует из-за того, что сценарий "geo-nearest" небезопасным образом обрабатывает временные файлы. Локальный пользователь может с помощью специально сформированной символической ссылки повысить свои привилегии на системе.

3. Уязвимость существует из-за того, что сценарий "gpssmswatch" и функция "signalposreq()" в файле splash.c небезопасным образом обрабатывает временные файлы. Локальный пользователь может с помощью специально сформированной символической ссылки повысить свои привилегии на системе.

URL производителя: gpsdrive.kraftvoll.at/index.shtml

URL производителя:

Решение: Установите исправление из SVN репозитория производителя.

Журнал изменений:

26.02.2009
Добавлено описании уязвимостей #2-3, изменена секция «Решение».

Ссылки: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=496436
http://lists.debian.org/debian-devel/2008/08/msg00285.html
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=508597

или введите имя

CAPTCHA