Уязвимость при обработке PPPoE пакетов в NetBSD

Дата публикации:
28.08.2008
Всего просмотров:
1979
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Локальная сеть
Воздействие:
Отказ в обслуживании
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
NetBSD 3.0
NetBSD 3.1
NetBSD 4.0
Уязвимые версии: NetBSD версии 3.0, 3.1 и 4.0

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании.

Уязвимость существует из-за некорректной проверки длины при обработке тегов в PPPoE пакете. Удаленный пользователь может с помощью специально сформированного PPoE пакета вызвать отказ в обслуживании системы. Для удачной эксплуатации уязвимости на системе должен быть создан PPPoE интерфейс и атакующий дожжен иметь возможность отправки PPPoE пакетов уязвимой системе.

URL производителя: www.netbsd.org

Решение: Установите исправление из CVS репозитория производителя.

Ссылки: NetBSD Security Advisory 2008-010: Malicious PPPoE discovery packet can overrun a kernel buffer

или введите имя

CAPTCHA