Отказ в обслуживании в GnuTLS

Дата публикации:
15.08.2008
Дата изменения:
15.08.2008
Всего просмотров:
1036
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
GnuTLS 2.x
Уязвимые версии: GnuTLS версии до 2.4.1

Описание:
Уязвимость позволяет удаленному пользователю произвести DoS атаку.

Уязвимость существует из-за повторного использования освобожденной памяти, когда приложение вызывает функцию "gnutls_handshake()" для уже существующей сессии. Удаленный пользователь может вызвать отказ в обслуживании.

URL производителя: www.gnu.org/software/gnutls/

Решение: Установите последнюю версию 2.4.1 с сайта производителя.

Ссылки: http://article.gmane.org/gmane.comp.encryption.gpg.gnutls.devel/2947

или введите имя

CAPTCHA