Несколько уязвимостей в Postfix

Дата публикации:
15.08.2008
Дата изменения:
18.08.2008
Всего просмотров:
1658
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2008-2936
CVE-2008-2937
Вектор эксплуатации:
Локальная
Воздействие:
Раскрытие важных данных
Повышение привилегий
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Postfix 2.x
Уязвимые версии: Postfix версии до 2.5.4 Patchlevel 4

Описание:
Уязвимость позволяет локальному пользователю получить доступ к важным данным и повысить свои привилегии на системе.

1. Уязвимость существует из-за того, что Postfix некорректно обрабатывает символические ссылки. Локальный пользователь может создать жесткую ссылку на символическую ссылку, принадлежащую пользователю root и дописать почтовые сообщения в произвольные файлы на системе. Для успешной эксплуатации уязвимости требуются привилегии на запись в директорию, где хранятся сообщения пользователей, и в этой директории не должно быть почтового ящика "root".

2. Уязвимость существует из-за того, что приложение некорректно проверяет права владения на файлы при доставке email сообщения. Злоумышленник может создать небезопасный файл для почтового ящика и просмотреть письма других пользователей. Для успешной эксплуатации уязвимости злоумышленник должен иметь привилегии на создание файла в директории, где хранятся сообщения пользователей.

URL производителя: www.postfix.org

Решение: Установите последнюю версию 2.5.4 Patchlevel 4 с сайта производителя.

Ссылки: http://de.postfix.org/ftpmirror/official/postfix-2.5.4.HISTORY

или введите имя

CAPTCHA