Множественные уязвимости в PHP

Дата публикации:
12.08.2008
Дата изменения:
31.01.2009
Всего просмотров:
2078
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Раскрытие важных данных
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
PHP 4.4.x
Уязвимые версии: PHP версии до 4.4.9

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю получить доступ к важным данным, вызвать отказ в обслуживании и скомпрометировать целевую систему.

1. Некоторые уязвимости в PCRE позволяют удаленному пользователю получить доступ к важным данным, вызвать отказ в обслуживании и скомпрометировать приложение, использующее уязвимую библиотеку. Подробное описание уязвимостей:
www.securitylab.ru/vulnerability/307022.php
www.securitylab.ru/vulnerability/313275.php

2. Уязвимость существует из-за неизвестной ошибки в "imageloadfont". Злоумышленник может с помощью некорректного шрифта вызвать отказ в обслуживании приложения.

3. Уязвимость существует из-за неизвестной ошибки в расширении "curl" при обработке "open_basedir".

URL производителя: www.php.net

Решение: Установите последнюю версию 4.4.9 с сайта производителя.

Ссылки: http://www.php.net/ChangeLog-4.php#4.4.9

или введите имя

CAPTCHA