Переполнение буфера в GIT

Дата публикации:
05.08.2008
Всего просмотров:
1612
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
GIT 1.x
Уязвимые версии: GIT 1.5.6.3, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании или скомпрометировать целевую систему.

Уязвимость существует из-за ошибки проверки границ данных в различных функциях при обработке слишком длинного пути. Злоумышленник может обманом заставить пользователя выполнить "git-diff" или "git-grep" для репозитория, который содержит в пути больше символов, чем указано в переменной "PATH_MAX" на целевой системе, вызвать переполнение стека и выполнить произвольный код на целевой системе.

URL производителя: www.kernel.org/pub/software/scm/git/docs/

Решение: Установите последнюю версию 1.5.6.4 с сайта производителя.

или введите имя

CAPTCHA