SQL-инъекция в E-Store Kit

Дата публикации:
05.08.2008
Дата изменения:
05.08.2008
Всего просмотров:
1423
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
E-Store Kit-1
E-Store Kit-1 Pro PayPal Edition
E-Store Kit-2
E-Store Kit-2 PayPal Edition
Уязвимые версии:
E-Store Kit-1
E-Store Kit-1 Pro PayPal Edition
E-Store Kit-2
E-Store Kit-2 PayPal Edition

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольные SQL команды в базе данных приложения.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "pid" в сценарии viewdetails.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

URL производителя: www.magicscripts.com/catalog.php?pid=28

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA