Переполнение буфера в OpenTTD

Дата публикации:
04.08.2008
Всего просмотров:
1094
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2008-3576
CVE-2008-3577
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
OpenTTD 0.x
Уязвимые версии: OpenTTD версии до 0.6.2

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании и скомпрометировать целевую систему.

Уязвимость существует из-за ошибки проверки границ данных в функции "TruncateString()" в файле src/gfx.cpp. Удаленный пользователь может с помощью специально сформированной строки вызвать переполнение буфера и выполнить произвольный код на целевой системе.

URL производителя: www.openttd.com

Решение: Установите последнюю версию 0.6.2 с сайта производителя.

или введите имя

CAPTCHA