Несколько уязвимостей в SocialEngine

Дата публикации:
28.07.2008
Всего просмотров:
2156
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2008-3297
CVE-2008-3298
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
SocialEngine 2.x
Уязвимые версии: SocialEngine версии до 2.83

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю выполнить произвольные SQL команды в базе данных приложения и скомпрометировать целевую систему.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре куки "se_user" в сценарии include/class_user.php и в параметре "se_admin" в сценарии include/class_admin.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

2. Уязвимость существует из-за недостаточной проверки входных данных при сохранении шаблонов. Удаленный пользователь может выполнить произвольный PHP код на целевой системе с привилегиями Web севера. Для успешной эксплуатации уязвимости требуются привилегии администратора приложения (см. уязвимости #1).

URL производителя: www.socialengine.net

Решение: Установите последнюю версию 2.83 с сайта производителя.

или введите имя

CAPTCHA