Небезопасная обработка временных файлов в Vim

Дата публикации:
21.07.2008
Дата изменения:
13.10.2008
Всего просмотров:
1462
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Локальная
Воздействие:
Повышение привилегий
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Vim 5.x
Vim 6.x
Vim 7.x
Уязвимые версии: Vim версии 5.0 по 7.1

Описание:
Уязвимость позволяет локальному пользователю повысить свои привилегии на системе.

Уязвимость существует из-за того, что файл src/configure.in небезопасным образом обрабатывает временные файлы. Локальный пользователь может с помощью специально сформированной символической ссылки и ошибки состояния операции повысить свои привилегии на системе. Для успешной эксплуатации уязвимости Vim должен быть сконфигурирован с опцией "--enable-pythoninterp".

URL производителя: www.vim.org

Решение: Установите последнюю версию 7.2 с сайта производителя.

Журнал изменений:

13.10.2008
Изменена секция «Решение».

Ссылки: http://seclists.org/fulldisclosure/2008/Jul/0312.html

или введите имя

CAPTCHA