PHP-инклюдинг в php Help Agent

Дата публикации:
17.07.2008
Всего просмотров:
1257
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Раскрытие важных данных
Раскрытие системных данных
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
php Help Agent 1.x
Уязвимые версии: php Help Agent 1.1, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю получить доступ к важным данным и выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "content" в сценарии include/head_chat.inc.php. Удаленный пользователь может с помощью специально сформированного запроса просмотреть произвольные файлы и выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals", "allow_url_fopen" и "allow_url_include" должны быть включены в конфигурационном файле PHP. Пример:

http://[host]/include/head_chat.inc.php?content=[file]

URL производителя: linuxwebshop.com/phphelpagent.php

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA