Инклюдинг локальных файлов в Zen Cart

Дата публикации:
14.07.2008
Дата изменения:
29.03.2009
Всего просмотров:
1833
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Раскрытие важных данных
Раскрытие системных данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Zen Cart 1.x
Уязвимые версии:Zen Cart 1.3.8, возможно более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю получить доступ к важным данным на системе.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "loader_file" в сценарии admin/includes/initsystem.php. Удаленный пользователь может с помощью специально сформированного запроса, содержащего символы обхода каталога, просмотреть содержимое произвольных файлов на системе. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/admin/includes/initsystem.php?loader_file=[file]

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "_SESSION[language]" в сценарии admin/includes/languages/english.php. Удаленный пользователь может с помощью специально сформированного запроса, содержащего символы обхода каталога, просмотреть содержимое произвольных файлов на системе. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена и опция "magic_quotes_gpc" отключена в конфигурационном файле PHP. Пример:

http://[host]/admin/includes/languages/english.php?_SESSION[language]=[file]

2.

URL производителя: www.zen-cart.com

Решение: Установите последнюю версию с сайта производителя.

Журнал изменений:
29.03.2009
Изменена секция "Решение"