Межсайтовый скриптинг в Drupal OpenID Module

Дата публикации:
11.07.2008
Всего просмотров:
1327
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Drupal OpenID Module 5.x
Уязвимые версии: Drupal OpenID Module версии до 5x.-1.2

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

1. Уязвимость существует из-за недостаточной обработки входных данных в OpenID провайдерах. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной проверки подлинности входных данных при обработке HTTP запросов. Удаленный пользователь может произвести CSRF атаку.

URL производителя: drupal.org/project/openid

Решение: Установите последнюю версию 5x.-1.2 с сайта производителя.

или введите имя

CAPTCHA