Межсайтовый скриптинг в vBulletin

Дата публикации:
10.07.2008
Всего просмотров:
2751
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
vBulletin 3.x
Уязвимые версии: vBulletin версии до 3.7.2 PL1 и 3.6.10 PL3

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в "PHP_SELF" или в параметре "do" при запросе несуществующей страницы. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта при просмотре журналов. Также сообщается, что злоумышленник может внедрить и выполнить произвольный PHP код на системе с привилегиями Web сервера.

URL производителя: www.vbulletin.com

Решение: Установите последнюю версию 3.7.2 PL1 или 3.6.10 PL3 с сайта производителя.

Ссылки: http://www.vbulletin.com/forum/showthread.php?t=277945

или введите имя

CAPTCHA