SQL-инъекция в BrewBlogger

Дата публикации:
10.07.2008
Дата изменения:
10.07.2008
Всего просмотров:
1071
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
BrewBlogger 2.x
Уязвимые версии: BrewBlogger 2.1.0.1, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольные SQL команды в базе данных приложения.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "username" в функции "authenticateUser()" в сценарии includes/authentication.inc.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

URL производителя: www.brewblogger.net

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: BrewBlogger 2.1.0.1 Arbitrary Add Admin Exploit

или введите имя

CAPTCHA