Отказ в обслуживании в Ruby

Дата публикации:
04.07.2008
Дата изменения:
17.09.2008
Всего просмотров:
1832
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Ruby 1.8.x
Уязвимые версии: Ruby 1.8.x

Описание:
Уязвимость позволяет удаленному пользователю произвести DoS атаку.

Целочисленное переполнение обнаружено в функции "rb_ary_fill()" при обработке слишком длинного списка аргументов. Удаленный пользователь может вызвать переполнение динамической памяти и аварийно завершить работу уязвимого приложения.

URL производителя: www.ruby-lang.org/en/

Решение: Установите исправление из SVN репозитория производителя.
http://svn.ruby-lang.org/cgi-bin/viewvc.cgi/trunk/array.c?r1=17472&r2=17756

или введите имя

CAPTCHA