Межсайтовый скриптинг в OpenCart

Дата публикации:
02.07.2008
Всего просмотров:
1167
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
OpenCart 0.x
Уязвимые версии: OpenCart 0.7.7, возможно более ранние версии

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "firstname" в сценарии index.php (когда параметр "controller" установлен в "account_create") и в параметре "search" в сценарии index.php (когда параметр "controller" установлен в "search" и параметр "action" установлен в "page"). Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: www.opencart.com

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA