Множественные уязвимости в S.T.A.L.K.E.R.: Shadow of Chernobyl

Дата публикации:
02.07.2008
Всего просмотров:
1803
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
S.T.A.L.K.E.R.: Shadow of Chernobyl 1.x
Уязвимые версии: S.T.A.L.K.E.R.: Shadow of Chernobyl 1.0006, возможно более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести DoS атаку и скомпрометировать целевую систему.

1. Уязвимость существует из-за ошибки проверки границ данных в функции MultipacketReciever::RecievePacket(). Удаленный пользователь может с помощью специально сформированного пакета, содержащего 0x39 в качестве первого байта, вызвать переполнение стека и выполнить произвольный код на целевой системе.

2. Уязвимость существует из-за недостаточной обработки входных данных в функции NET_Compressor::Decompress(). Удаленный пользователь может с помощью специально сформированного пакета, содержащего байт 0xc1, вызвать переполнение буфера и скомпрометировать целевую систему.

3. Уязвимость существует из-за ошибки в функции MultipacketReciever::RecievePacket(). Удаленный пользователь может с помощью специально сформированного пакета аварийно завершить работу сервера.

URL производителя: www.stalker-game.com

Решение: Способов устранения уязвимости не существует в настоящее время.

Ссылки: S.T.A.L.K.E.R.: Shadow of Chernobyl Multiple Vulnerabilities PoC

или введите имя

CAPTCHA