Межсайтовый скриптинг в Caucho Resin

Дата публикации:
26.06.2008
Дата изменения:
26.06.2008
Всего просмотров:
1396
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Caucho Resin 3.x
Уязвимые версии: Caucho Resin версии до 3.0.25 и 3.1.4

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "file" в команде "viewfile" в документации к Resin. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: www.caucho.com/resin/index.xtp

Решение: Установите последнюю версию 3.0.25 или 3.1.4 с сайта производителя.

Ссылки: http://www.kb.cert.org/vuls/id/305208

или введите имя

CAPTCHA