Переполнение буфера в IBM AFP Viewer Plug-In

Дата публикации:
26.06.2008
Дата изменения:
26.06.2008
Всего просмотров:
1388
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
IBM AFP Viewer Plug-In 2.x
IBM AFP Viewer Plug-In 3.x
Уязвимые версии: IBM AFP Viewer Plug-In 2.0.7.1 и 3.2.1.1, возможно другие версии

Описание:
Уязвимость позволяет удаленному пользователю скомпрометировать целевую систему.

Уязвимость существует из-за ошибки проверки границ данных в плагине при обработке свойства "SRC". Удаленный пользователь может с помощью слишком длинной строки (более 1023 символов) вызвать переполнение динамической памяти и выполнить произвольный код на целевой системе.

URL производителя: www.ibm.com

Решение: Установите последнюю версию 3.4.1.7 с сайта производителя.

Ссылки: http://www-1.ibm.com/support/docview.wss?rs=95&context=SRNPPZ&q=psd1*&uid=psd1P4000233

или введите имя

CAPTCHA