Несколько уязвимостей в Academic Web Tools

Дата публикации:
25.06.2008
Всего просмотров:
1350
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2008-2967
CVE-2008-2968
CVE-2008-2969
CVE-2008-2970
CVE-2008-2878
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Неавторизованное изменение данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Academic Web Tools 1.x
Уязвимые версии: Academic Web Tools 1.4.3.1 и более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение и выполнить произвольные SQL команды в базе данных приложения.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "Fake" в сценарии login.php, в параметре "file" в сценарии rss_getfile.php, и в параметре "glb_sid" в сценарии hta/htmlarea.js.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "book_id" в сценарии rating.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

URL производителя: www.yektaweb.com

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA