Межсайтовый скриптинг в phpMyAdmin

Дата публикации:
24.06.2008
Всего просмотров:
2205
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
phpMyAdmin 1.x
phpMyAdmin 2.x
Уязвимые версии: phpMyAdmin версии до 2.11.7

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных в различных параметрах в файлах каталога /libraries. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP.

URL производителя: www.phpmyadmin.net

Решение: Установите последнюю версию 2.11.7 с сайта производителя.

Ссылки: http://www.phpmyadmin.net/home_page/security.php?issue=PMASA-2008-4

или введите имя

CAPTCHA