PHP-инклюдинг в Dagger

Дата публикации:
24.06.2008
Всего просмотров:
1390
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Dagger
Уязвимые версии: Dagger

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметрах "dir_inc" и "dir_edge_skins" в сценарии skins/default.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/skins/default.php?dir_inc=[file]

URL производителя: labs.geody.com/dagger/

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA