PHP-инклюдинг в Hedgehog-CMS

Дата публикации:
23.06.2008
Всего просмотров:
1156
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Раскрытие важных данных
Раскрытие системных данных
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Hedgehog-CMS 1.x
Уязвимые версии: Hedgehog-CMS 1.21, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "c_temp_path" в сценарии includes/header.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опции "allow_url_fopen" и "allow_url_include" должны быть включены в конфигурационном файле PHP. Пример:

http://[host]/includes/header.php?c_temp_path=[file]

URL производителя: hedgehog-cms.sourceforge.net

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA