PHP-инклюдинг в Jamroom

Дата публикации:
23.06.2008
Всего просмотров:
4621
Опасность:
Высокая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2008-2886
CVE-2008-2883
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Jamroom 3.x
Уязвимые версии: Jamroom версии до 3.3.6

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "jamroom[jm_dir]" в сценариях include/plugins/jrBrowser/purchase.php и include/plugins/jrBrowser/payment.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/include/plugins/jrBrowser/purchase.php?jamroom[jm_dir]=[file]

URL производителя: jamroom.net

Решение: Установите последнюю версию 3.3.6 с сайта производителя.

или введите имя

CAPTCHA