PHP-инклюдинг в MiGCMS

Дата публикации:
23.06.2008
Всего просмотров:
920
Опасность:
Высокая
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
MiGCMS 2.x
Уязвимые версии: MiGCMS 2.0.5, возможно другие версии.

Описание:
Уязвимость позволяет удаленному пользователю выполнить произвольный PHP сценарий на целевой системе.

Уязвимость существует из-за недостаточной обработки входных данных в параметре "GLOBALS[application][app_root]" в сценариях lib/obj/collection.class.php и lib/obj/content_image.class.php. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный PHP сценарий на целевой системе с привилегиями Web сервера. Для удачной эксплуатации уязвимости опция "register_globals" должна быть включена в конфигурационном файле PHP. Пример:

http://[host]/lib/obj/collection.class.php?GLOBALS[application][app_root]=[file]

URL производителя: sourceforge.net/projects/migcms/

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA