Межсайтовый скриптинг в Adobe Flex

Дата публикации:
18.06.2008
Всего просмотров:
1159
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
Нет данных
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Adobe Flex 3.x
Уязвимые версии: Adobe Flex 3.0.1 SDK и Flex Builder 3

Описание:
Уязвимость позволяет удаленному пользователю произвести XSS нападение.

Уязвимость существует из-за недостаточной обработки входных данных, передаваемых сценарию historyFrame.html, который используется в Flex 3 History Management. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: www.adobe.com/products/flex/

Решение: Установите последнюю версию 3.0.2 SDK и обновите файл historyFrame.html для ранее разработанных Flex 3 web приложений.

Ссылки: APSB08-14: Update to Flex 3 to address potential cross-site scripting vulnerability

или введите имя

CAPTCHA