Несколько уязвимостей в WallCity-Server Shoutcast Admin Panel

Дата публикации:
16.06.2008
Всего просмотров:
1140
Опасность:
Средняя
Наличие исправления:
Нет
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2008-2813
CVE-2008-2814
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Раскрытие важных данных
Раскрытие системных данных
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
WallCity-Server Shoutcast Admin Panel 2.x
Уязвимые версии: WallCity-Server Shoutcast Admin Panel 2.1, возможно более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение и получить доступ к важным данным.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "page" в сценарии index.php. Удаленный пользователь может с помощью специально сформированного запроса, содержащего символы обхода каталога, просмотреть содержимое произвольных файлов на системе.Для успешной эксплуатации уязвимости опция "magic_quotes_gpc" должна быть отключена в конфигурационном файле PHP. Пример:

http://[host]/index.php?page=../../../../../../etc/passwd%00

2. Уязвимость существует из-за недостаточной обработки входных данных в параметре "username". Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

URL производителя: sourceforge.net/projects/shoutcastadmin/

Решение: Способов устранения уязвимости не существует в настоящее время.

или введите имя

CAPTCHA