Множественные уязвимости в Gallery

Дата публикации:
12.06.2008
Дата изменения:
12.06.2008
Всего просмотров:
1125
Опасность:
Низкая
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2008-2720
CVE-2008-2721
CVE-2008-2722
CVE-2008-2723
CVE-2008-2724
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Раскрытие важных данных
Раскрытие системных данных
Неавторизованное изменение данных
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Gallery 2.x
Уязвимые версии: Gallery версии до 2.2.5

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю обойти ограничения безопасности, произвести XSS нападение, получить доступ к важным данным и скомпрометировать целевую систему.

1. Уязвимость существует из-за недостаточной обработки входных данных в URL. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточного ограничения доступа в модуле album-select. Удаленный пользователь может просмотреть названия скрытых альбомов и добавить новые альбомы к скрытым альбомам.

3. Уязвимость существует из-за недостаточного ограничения доступа при распаковке ZIP архивов. Удаленный пользователь может создать новые альбомы не имея соответствующих привилегий.

4. Уязвимость существует из-за неизвестной ошибки в сценарии embed.php, которая позволяет удаленному пользователю получить данные об установочной директории приложения на системе.

5. Уязвимость существует из-за некорректного ограничения доступа в модуле Password. Удаленный пользователь может обойти ограничение доступа к отдельным элементам, не входящим в состав альбома.

URL производителя: gallery.menalto.com

Решение: Установите последнюю версию 2.2.5 с сайта производителя.

или введите имя

CAPTCHA