Множественные уязвимости в Drupal Aggregation Module

Дата публикации:
12.06.2008
Всего просмотров:
1509
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2008-2998
CVE-2008-2999
CVE-2008-3000
CVE-2008-3001
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Неавторизованное изменение данных
Обход ограничений безопасности
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Drupal Aggregation Module 5.x
Уязвимые версии: Drupal Aggregation Module версии до 5.x-4.4

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю обойти некоторые ограничения безопасности, произвести XSS нападение, выполнить произвольные SQL команды и скомпрометировать целевую систему.

1. Уязвимость существует из-за недостаточной обработки входных данных. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

2. Уязвимость существует из-за недостаточной обработки входных данных. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

3. Уязвимость существует из-за ошибки, которая позволяет загрузить произвольные файлы посредством злонамеренных новостных каналов. В зависимости от конфигурации сервера, злоумышленник может выполнить произвольный код на целевой системе.

4. Уязвимость существует из-за ошибок в реализации списков контроля доступа. Удаленный пользователь может обойти некоторые ограничения безопасности.

URL производителя: drupal.org/project/aggregation

Решение: Установите последнюю версию 5.x-4.4 с сайта производителя.

или введите имя

CAPTCHA