Множественные уязвимости в TYPO3

Дата публикации:
11.06.2008
Всего просмотров:
989
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2008-2717
CVE-2008-2718
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
TYPO3 3.x
TYPO3 4.x
Уязвимые версии: TYPO3 версии до 4.0.9, 4.1.7 и 4.2.1

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю произвести XSS нападение и скомпрометировать целевую систему.

1. Уязвимость существует из-за ошибки при обработке нескольких расширений загружаемых файлов, например "file.php.1" или файлов, начинающихся с точки, например ".htaccess". Удаленный пользователь может выполнить произвольный код на целевой системе. Для успешной эксплуатации уязвимости требуется определенная конфигурация Web сервера. Также требуются действительные учетные данные для доступа к бекэнд серверу и доступ к точкам монтирования или наличие установленных плагинов t3lib_div::verifyFilenameAgainstDenyPattern()" или "processFiles()".

2. Уязвимость существует из-за недостаточной обработки входных данных в сценарии fe_adminlib.inc. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта. Для успешной эксплуатации уязвимости должно быть установлено расширение direct_mail_subscription, feuser_admin или kb_md5fepw.

URL производителя: www.typo3.com

Решение: Установите последнюю версию 4.0.9, 4.1.7 или 4.2.1 с сайта производителя.

или введите имя

CAPTCHA