Выполнение произвольного кода в ядре Linux

Дата публикации:
10.06.2008
Дата изменения:
18.08.2008
Всего просмотров:
1370
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2008-1673
CVE-2008-2358
Вектор эксплуатации:
Удаленная
Воздействие:
Отказ в обслуживании
Компрометация системы
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Linux Kernel 2.6.x
Уязвимые версии: Linux kernel 2.6.18, возможно другие версии

Описание:
Уязвимость позволяет удаленному пользователю вызвать отказ в обслуживании и скомпрометировать целевую систему.

Уязвимость существует из-за недостаточной проверки входных данных в функции "dccp_feat_change()" файла net/dccp/feat.c в подсистеме DCCP (Datagram Congestion Control Protocol). Удаленный пользователь может вызвать переполнение буфера и выполнить произвольный код на целевой системе.

URL производителя: www.kernel.org

Решение: Установите последнюю версию с сайта производителя. Некоторые производители Linux систем выпустили исправления.

Журнал изменений:


10.08.2008
Изменена секция "Решение".

Ссылки: [DSA 1592-2] New Linux 2.6.18 packages fix overflow conditions

или введите имя

CAPTCHA