Множественные уязвимости в Realm CMS

Дата публикации:
10.06.2008
Дата изменения:
18.08.2008
Всего просмотров:
900
Опасность:
Средняя
Наличие исправления:
Да
Количество уязвимостей:
1
CVSSv2 рейтинг:
CVE ID:
CVE-2008-2679
CVE-2008-2680
CVE-2008-2681
CVE-2008-2682
Вектор эксплуатации:
Удаленная
Воздействие:
Межсайтовый скриптинг
Раскрытие системных данных
Неавторизованное изменение данных
Обход ограничений безопасности
CWE ID:
Нет данных
Наличие эксплоита:
Нет данных
Уязвимые продукты:
Realm CMS 2.x
Уязвимые версии: Realm CMS 2.3, возможно более ранние версии

Описание:
Обнаруженные уязвимости позволяют удаленному пользователю обойти некоторые ограничения безопасности, произвести XSS нападение, выполнить произвольные SQL команды и получить доступ к важным данным.

1. Уязвимость существует из-за недостаточной обработки входных данных в параметре "kwrd" в сценарии _includes/inc_routines.asp. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольные SQL команды в базе данных приложения.

2. Уязвимость существует из-за недостаточной обработки входных данных в параметрах "CmpctedDB" и "Boyut" в сценарии _db/compact.asp. Удаленный пользователь может с помощью специально сформированного запроса выполнить произвольный код сценария в браузере жертвы в контексте безопасности уязвимого сайта.

3. Уязвимость существует из-за того, что злоумышленник может вызвать сценарий _db/compact.asp и получить данные об установочной директории приложения.

4. Уязвимость существует из-за недостаточного ограничения доступа в сценарии _RealmAdmin/login.asp. Удаленный пользователь может с помощью специально сформированного файла куки обойти механизм аутентификации и получить доступ к административной части приложения.

URL производителя: realmproject.com/RealmCMS/

Решение: Установите последнюю версию с сайта производителя.

Журнал изменений:


10.08.2008
Изменена секция "Решение".

или введите имя

CAPTCHA